$re = '/^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{8,32}$/m';
$str = 'thisisalongpassword1ABC
thisisALSOalongPASSWORDwith%%%%3
thisisaninvalidpasswo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);