re = /^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{8,32}$/m
str = 'thisisalongpassword1ABC
thisisALSOalongPASSWORDwith%%%%3
thisisaninvalidpasswo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end