package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)INSERT INTO(.|\n|\r)*\)`)
var str = `INSERT INTO (фывфыв ( фывфыв) ) фывфывф)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}