import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.?(?!@)).*?((?<!^).)?@(.(?!$))?.*?((?<!@).?)$";
final String string = "a@a\n"
+ "a@aa\n"
+ "aa@a\n"
+ "ww@ww\n"
+ "name@mail.com\n"
+ "f@mail.com";
final String subst = "\\1***\\2@\\3***\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}