import re
regex = re.compile(r"^(.?(?!@)).*?((?<!^).)?@(.(?!$))?.*?((?<!@).?)$", flags=re.MULTILINE)
test_str = ("a@a\n"
"a@aa\n"
"aa@a\n"
"ww@ww\n"
"name@mail.com\n"
"f@mail.com")
subst = "\\1***\\2@\\3***\\4"
result = regex.sub(subst, test_str)
if result:
print(result)