using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:""([^""}]*)"")|(\w+))\s*:\s*(?:(?:""([^""}]*)"")|(\w+))";
string input = @"{
""data"":"" "",
""displayException"":""Unable to authenticate user. Please make sure you have an existing account. If you do not, select Register to create an account. Please contact 1-234-567-8910 M-F 9a-5pm CT for further assistance."",
""exception"":""UNABLE TO LOGIN"",
""success"":false,
""failed"": true,
id : one_number
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}