package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:"([^"}]*)")|(\w+))\s*:\s*(?:(?:"([^"}]*)")|(\w+))`)
var str = `{
"data":" ",
"displayException":"Unable to authenticate user. Please make sure you have an existing account. If you do not, select Register to create an account. Please contact 1-234-567-8910 M-F 9a-5pm CT for further assistance.",
"exception":"UNABLE TO LOGIN",
"success":false,
"failed": true,
id : one_number
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}