$re = '/^ *(\d*) *(\d*) *(\d+\.\d+)(.*)(\(\d+\))$/m';
$str = ' 0000000125 1478759 9.2 The Shawshank Redemption (1994)
0000000125 1014575 9.2 The Godfather (1972)
0000000124 683611 9.0 The Godfather: Part II (1974)
0000000124 1451861 8.9 The Dark Knight (2008)
0000000124 1150611 8.9 Pulp Fiction (1994)
0000000133 750978 8.9 Schindler\'s List (1993)';
$subst = "$1 $2 $3 $4 $5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;