# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ *(\d*) *(\d*) *(\d+\.\d+)(.*)(\(\d+\))$"
test_str = (" 0000000125 1478759 9.2 The Shawshank Redemption (1994)\n"
" 0000000125 1014575 9.2 The Godfather (1972)\n"
" 0000000124 683611 9.0 The Godfather: Part II (1974)\n"
" 0000000124 1451861 8.9 The Dark Knight (2008)\n"
" 0000000124 1150611 8.9 Pulp Fiction (1994)\n"
" 0000000133 750978 8.9 Schindler's List (1993)")
subst = "$1 $2 $3 $4 $5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.