re = /(?![EB]#)([A-G])([#b])?/m
str = 'A
A#
Ab
B
B#
Bb
C
C#
Cb
D
D#
Db
E
E#
Eb
F
F#
Fb
G
G#
Gb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end