$re = '/^(?!.*saturday)(?!.*sunday).*(brunch)/im';
$str = 'Valid for brunch on Saturdays and Sundays
Valid for brunch ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);