re = /^(?!.*saturday)(?!.*sunday).*(brunch)/im
str = 'Valid for brunch on Saturdays and Sundays
Valid for brunch '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end