const regex = /-\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d+$', 'gm')
const str = `kids-and-babies
kids-girls-1224
beauty
dresses-281`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);