use strict;
my $str = 'kids-and-babies
kids-girls-1224
beauty
dresses-281';
my $regex = qr/-\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";