#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(?<!\w)(\s*)@embed(\s*\(.*?\))((?:(.*?)@endembed|(?R))*+)"
Local $sString = "@extends('layouts/default')" & @CRLF & _
"" & @CRLF & _
"@section('content')" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="col-md-6">" & @CRLF & _
" @embed('components/box')" & @CRLF & _
" @section('title', 'Box title')" & @CRLF & _
" @section('content')" & @CRLF & _
" <h4>Haai</h4>" & @CRLF & _
" Box content" & @CRLF & _
" @stop" & @CRLF & _
" @endembed" & @CRLF & _
" </div>" & @CRLF & _
" <div class="col-md-6">" & @CRLF & _
"" & @CRLF & _
" @embed('components/box')" & @CRLF & _
" @section('title', 'Box2 title')" & @CRLF & _
" @section('content')" & @CRLF & _
"" & @CRLF & _
" @embed('components/timeline')" & @CRLF & _
" @section('items')" & @CRLF & _
" @stop" & @CRLF & _
" @endembed" & @CRLF & _
"" & @CRLF & _
" @stop" & @CRLF & _
" @endembed" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"@stop" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")