re = /(?<!\w)(\s*)@embed(\s*\(.*?\))((?:(.*?)@endembed|(?R))*+)/i
str = '@extends(\'layouts/default\')
@section(\'content\')
<div class="row">
<div class="col-md-6">
@embed(\'components/box\')
@section(\'title\', \'Box title\')
@section(\'content\')
<h4>Haai</h4>
Box content
@stop
@endembed
</div>
<div class="col-md-6">
@embed(\'components/box\')
@section(\'title\', \'Box2 title\')
@section(\'content\')
@embed(\'components/timeline\')
@section(\'items\')
@stop
@endembed
@stop
@endembed
</div>
</div>
@stop
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end