#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-z]+://\S+"
Local $sString = "Test text http://hello.world Test text " & @CRLF & _
"http://google.com/file.jpg Test text https://hell.o.wor.ld/test?qwe=qwe Test text " & @CRLF & _
"test text http://test.test/test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")