import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z]+://\\S+";
final String string = "Test text http://hello.world Test text \n"
+ "http://google.com/file.jpg Test text https://hell.o.wor.ld/test?qwe=qwe Test text \n"
+ "test text http://test.test/test";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}