package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)translate\(
(['"])
(?:(?!\1).)*
\1
\)`)
var str = `translate("some text here")
translate('some text here')
translate('"some text here..."')
translate("a"b"c"d")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}