re = /translate\(
(['"])
(?:(?!\1).)*
\1
\)/x
str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate("a"b"c"d")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end