$re = '~/(?=(?:(?:[^\']*\'){2})*[^\']*$)~';
$str = 'ListOfItems/Item[Name=\'Model/Id\']/Price';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);