re = /\/(?=(?:(?:[^']*'){2})*[^']*$)/
str = 'ListOfItems/Item[Name=\'Model/Id\']/Price'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end