const regex = /(\d+)\s\(\s(\d+)\s\)|(\d+)(?=\s\(\s(?:\d+\s\(\s\d+\s\)\s)+(\d+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s\\(\\s(\\d+)\\s\\)|(\\d+)(?=\\s\\(\\s(?:\\d+\\s\\(\\s\\d+\\s\\)\\s)+(\\d+))', 'g')
const str = `3 ( 16 ) 23 ( 24 ( 40 ) 50 ( 66 ) 76 ) 83 ( 88 ( 104 ) 127 )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}