$re = '/TMCA*/ms';
$str = 'Request distribution failed
TMCA154891769
TMCA796121323
This error is a shit
I want this done
----------------
bla bla
Code: 141u231
--------------';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);