import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![^<]*>)[a-zA-Z\\/\\/:\\.]*youtu(be.com\\/watch\\?v=|.be\\/)([a-zA-Z0-9\\-_]+)";
final String string = "Hello world!\n\n"
+ "<a href=\"https://www.youtube.com/watch?v=m7t75u72vd\">ABC</a>\n\n"
+ "Blah blah blah...\n\n"
+ "https://www.youtube.com/watch?v=df82vnx07s\n\n"
+ "Blah blah blah...\n"
+ "<p>https://www.youtube.com/watch?v=nvs70fh17f3fg</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}