import re
regex = re.compile(r"(?![^<]*>)[a-zA-Z\/\/:\.]*youtu(be.com\/watch\?v=|.be\/)([a-zA-Z0-9\-_]+)")
test_str = ("Hello world!\n\n"
"<a href=\"https://www.youtube.com/watch?v=m7t75u72vd\">ABC</a>\n\n"
"Blah blah blah...\n\n"
"https://www.youtube.com/watch?v=df82vnx07s\n\n"
"Blah blah blah...\n"
"<p>https://www.youtube.com/watch?v=nvs70fh17f3fg</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")