$re = '/([\/.*)($.+|^?!`\[\]-])(?!(?:(?!{%).)*?%})/';
$str = '"This is test. ! {%.?{1}.%} . and it doesn\'t work"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);