re = /([\/.*)($.+|^?!`\[\]-])(?!(?:(?!{%).)*?%})/
str = '"This is test. ! {%.?{1}.%} . and it doesn\'t work"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end