#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\{\{ *(ab|cd|ef|gh) *\}\} *\{\{ *(ab|cd|ef|gh) *\}\} *(\{\{ *(ab|cd|ef|gh) *\}\})* *(\{\{ *(ab|cd|ef|gh) *\}\})* *(\{\{ *(ab|cd|ef|gh) *\}\})* *(\{\{ *(ab|cd|ef|gh) *\}\})*"
Local $sString = "{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}" & @CRLF & _
"{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}" & @CRLF & _
"machintruc {{ab}} {{cd}}" & @CRLF & _
"{{ab}} {{cd}} {{ef}} [https://truc.org truc]" & @CRLF & _
"{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{lien web|url=tr.uc}}" & @CRLF & _
"{{mr}} Trucmuche" & @CRLF & _
""
Local $sSubst = "{{mul|$1|$2|$4|$6|$8|$10}} "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)