import re
regex = re.compile(r"^(?=.{2,50}$)[A-ZÆØÅa-zæøå]+(?: [A-ZÆØÅa-zæøå]+)*(?:-[A-ZÆØÅa-zæøå]+(?: [A-ZÆØÅa-zæøå]+)*)?$", flags=re.MULTILINE)
test_str = ("Janet Smith-Johnson\n"
"Mary-Ann Johnson\n"
"Sara Mary John-Smith\n"
"Sara Johnson\n"
"Sara Mary Johnson\n\n"
"-Janet Mary\n"
"Mary-\n\n"
" - ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")