$re = '/\S+(?=\n\n)/m';
$str = '"H:\\S\\recup_dir.17\\f171236272.mp3"
"H:\\S\\recup_dir.8\\f37197984.mp3"
"H:\\S\\recup_dir.16\\f168470040.gz"
"H:\\S\\recup_dir.17\\f170038264.gz"
"H:\\S\\recup_dir.18\\f218780056.mp3"
"H:\\S\\recup_dir.9\\f46500864.mp3"
"H:\\S\\recup_dir.1\\f0712280.mp3"
"H:\\S\\recup_dir.20\\f330856896.mp3"
"H:\\S\\recup_dir.20\\f304869798.mp3"
"H:\\S\\recup_dir.9\\f50157574.mp3"
"H:\\S\\recup_dir.19\\f246711560.mp3"
"H:\\S\\recup_dir.9\\f49831408.mp3"
"H:\\S\\recup_dir.14\\f108337512.mp3"
"H:\\S\\recup_dir.2\\f8089064.mp3"
"H:\\S\\recup_dir.16\\f152853840.mp3"
"H:\\S\\recup_dir.20\\f315839720.mp3"
"H:\\S\\recup_dir.8\\f38617728.mp3"
"H:\\S\\recup_dir.22\\f414604664.mp3"
"H:\\S\\recup_dir.8\\f38191280.mp3"
"H:\\S\\recup_dir.10\\f52349328.mp3"
"H:\\S\\recup_dir.22\\f415832696.mp3"
"H:\\S\\recup_dir.17\\f171137807.mp3"
"H:\\S\\recup_dir.20\\f303943983.mp3"
"H:\\S\\recup_dir.8\\f37378127.mp3"
"H:\\S\\recup_dir.15\\f123439872.mp3"
"H:\\S\\recup_dir.2\\f7974272.mp3"
"H:\\S\\recup_dir.2\\f6994232.mp3"
"H:\\S\\recup_dir.20\\f281329576.mp3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);