# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\S+(?=\n\n)"
test_str = ("\"H:\\S\\recup_dir.17\\f171236272.mp3\"\n"
"\"H:\\S\\recup_dir.8\\f37197984.mp3\"\n\n"
"\"H:\\S\\recup_dir.16\\f168470040.gz\"\n"
"\"H:\\S\\recup_dir.17\\f170038264.gz\"\n\n"
"\"H:\\S\\recup_dir.18\\f218780056.mp3\"\n"
"\"H:\\S\\recup_dir.9\\f46500864.mp3\"\n\n"
"\"H:\\S\\recup_dir.1\\f0712280.mp3\"\n"
"\"H:\\S\\recup_dir.20\\f330856896.mp3\"\n\n"
"\"H:\\S\\recup_dir.20\\f304869798.mp3\"\n"
"\"H:\\S\\recup_dir.9\\f50157574.mp3\"\n\n"
"\"H:\\S\\recup_dir.19\\f246711560.mp3\"\n"
"\"H:\\S\\recup_dir.9\\f49831408.mp3\"\n\n"
"\"H:\\S\\recup_dir.14\\f108337512.mp3\"\n"
"\"H:\\S\\recup_dir.2\\f8089064.mp3\"\n\n"
"\"H:\\S\\recup_dir.16\\f152853840.mp3\"\n"
"\"H:\\S\\recup_dir.20\\f315839720.mp3\"\n"
"\"H:\\S\\recup_dir.8\\f38617728.mp3\"\n\n"
"\"H:\\S\\recup_dir.22\\f414604664.mp3\"\n"
"\"H:\\S\\recup_dir.8\\f38191280.mp3\"\n\n"
"\"H:\\S\\recup_dir.10\\f52349328.mp3\"\n"
"\"H:\\S\\recup_dir.22\\f415832696.mp3\"\n\n"
"\"H:\\S\\recup_dir.17\\f171137807.mp3\"\n"
"\"H:\\S\\recup_dir.20\\f303943983.mp3\"\n"
"\"H:\\S\\recup_dir.8\\f37378127.mp3\"\n\n"
"\"H:\\S\\recup_dir.15\\f123439872.mp3\"\n"
"\"H:\\S\\recup_dir.2\\f7974272.mp3\"\n\n"
"\"H:\\S\\recup_dir.2\\f6994232.mp3\"\n"
"\"H:\\S\\recup_dir.20\\f281329576.mp3\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.