import re
regex = re.compile(r"(?:google|yahoo)(?:\.com)?(*SKIP)(*F)|", flags=re.MULTILINE)
test_str = (" I like foobar.com\n"
" I like google.com and foobar.com\n"
" I like foobar.com and google.com\n"
" I like foobargoogle.com and googlefoobar.com\n"
" I like yahoo.com and foobar.com\n"
" I like foobar.com and yahoo.com\n"
" I like foobaryahoo.com and yahoofoobar.com\n\n\n"
" I like yahoo.com\n"
" I like foobaryahoo.com\n"
" I like google.com\n"
" I like foobargoogle.com\n"
" I like google.com and yahoo.com\n"
" I like foobargoogle.com and foobaryahoo.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")