// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:google|yahoo)(?:\.com)?(*SKIP)(*F)|").unwrap();
let string = " I like foobar.com
I like google.com and foobar.com
I like foobar.com and google.com
I like foobargoogle.com and googlefoobar.com
I like yahoo.com and foobar.com
I like foobar.com and yahoo.com
I like foobaryahoo.com and yahoofoobar.com
I like yahoo.com
I like foobaryahoo.com
I like google.com
I like foobargoogle.com
I like google.com and yahoo.com
I like foobargoogle.com and foobaryahoo.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}