$re = '/^(-\w+\s*.*)\n*$/um';
$str = '-Give on result
-Second new text
-The third text
Another paragraph without list.
-New list here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);