$re = '~\w+ing\b~';
$str = 'cats
and
dogs
are
running
around
|
john
loves
mary
|
I
am
swimming
|';
$subst = "$0 CC";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;