re = /\w+ing\b/
str = 'cats
and
dogs
are
running
around
|
john
loves
mary
|
I
am
swimming
|'
subst = '$0 CC'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result