#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:\/\/|)(.*?)(\/.*|)$"
Local $sString = "example.com" & @CRLF & _
"example.com/poooj" & @CRLF & _
"http://example.com/" & @CRLF & _
"http://example.com" & @CRLF & _
"https://example.com/dddeef" & @CRLF & _
"http://example.com/?" & @CRLF & _
"http://example.com//"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")