package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/|)(.*?)(\/.*|)$`)
var str = `example.com
example.com/poooj
http://example.com/
http://example.com
https://example.com/dddeef
http://example.com/?
http://example.com//`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}