$re = '/^(?:https?:\/\/)?(?:[^\.]+\.)?example\.com(\/.*)?$/m';
$str = 'https://example.com
http://www.example.com
http://example.com
https://example.com
www.example.com
example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);