package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:&\[).+?(?:\]))+`)
var str = `[Product].[Product Catalog].[Product].&[50]&[53]&[DE]&[1ST_HQ]&[50_54_36]
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}