const regex = /((?:&\[).+?(?:\]))+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:&\\[).+?(?:\\]))+', '')
const str = `[Product].[Product Catalog].[Product].&[50]&[53]&[DE]&[1ST_HQ]&[50_54_36]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}