using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node_modules\/(?!(atest)\/)";
string input = @"/node_modules/atest/index.js
/node_modules/react/index.js
/node_modules/lodash/index.js
/node_modules/dayjs/index.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}