re = /node_modules\/(?!(atest)\/)/m
str = '/node_modules/atest/index.js
/node_modules/react/index.js
/node_modules/lodash/index.js
/node_modules/dayjs/index.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end