import re
regex = re.compile(r"^PATIENT:.*-\s+([^.]*?)\s*\.", flags=re.MULTILINE)
test_str = ("PATIENT: 2029985 - COLLINS, JUNIOR .\n"
"PATIENT: 1235231-02 - JERRY JR, PATRICK .\n"
"PATIENT: 986435--EXP-- - JULIUS, DANIEL .\n"
"PATIENT: 2021118-02 - DRED-HARRY, KEVIN .")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")