re = /([0-9]+,[0-9]+|[0-9]+) (GB|MB) \(([0-9]+,[0-9]+|[0-9]+) [a-zA-Z]+[\/|`]s ?\)/
str = '5 GB (42,2 Mbit`s )
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end