#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?(?:instagram\.com\/p\/)([\d\w\-_]+)(?:\/)?(\?.*)?$"
Local $sString = "https://www.instagram.com/p/BxKRx5CHn5i/" & @CRLF & _
"https://www.instagram.com/p/BrODg5XHlE6/?utm_source=ig_share_sheet&igshid=znsinsart176" & @CRLF & _
"https://www.instagram.com/p/BxKRx5CHn5i/" & @CRLF & _
"https://www.instagram.com/username/p/BxE5PpZhoa9/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")