package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)?(?:www\.)?(?:instagram\.com\/p\/)([\d\w\-_]+)(?:\/)?(\?.*)?$`)
var str = `https://www.instagram.com/p/BxKRx5CHn5i/
https://www.instagram.com/p/BrODg5XHlE6/?utm_source=ig_share_sheet&igshid=znsinsart176
https://www.instagram.com/p/BxKRx5CHn5i/
https://www.instagram.com/username/p/BxE5PpZhoa9/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}