package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^[_0-9]+]`)
var str = `CHST_PORD_000000422438
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}