$re = '/[^[_0-9]+]/';
$str = 'CHST_PORD_000000422438
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);